UT3 Converter

User Guide V0.1-Reference version :V0.22
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Description
UT3 Converter is a java program that allows porting partially maps from previous Unreal Tournament
games series to Unreal Tournament 3.

Supported UTx games
The current input game-maps supported are Unreal 1, Unreal 2, Unreal Tournament (aka UT99),
Unreal Tournament 2003 and Unreal Tournament 2004.

Supported Tested

Unreal 1 X X
Unreal 2 X X
Unreal Tournament X X
Unreal Tournament 2003 X

Unreal Tournament 2004 X X

Class converted
UT3 Converter does not convert all actors within a UTx map to Unreal Tournament 3.

Here are the different classes/stuff that are converted:

| - Unreall ~  Unreal2 UT99 ~UT2003 ~UT2004

Custom code No No No No No
Textures X X X X X
Static Meshes N/A No N/A No X
Sounds X
Weapons X X
Brushes X X X X X
Navigation X X X X
Points

Pickups X X
Lights X X X X
Terrain N/A No N/A No No

UT2004 converted classes:

[Brush, WaterVolume, LavaVolume, BlockingVolume, PhysicsVolume, xFallingVolume, Light,
AmbientSound, MiniHealthPack, HealthCharger, SuperHealthCharger, LinkAmmoPickup,
BioAmmoPickup, ClassicSniperAmmoPickup, FlakAmmoPickup, ONSAVRiLAmmoPickup,
RocketAmmoPickup, ShockAmmoPickup, SniperAmmoPickup, xWeaponBase, NewWeaponBase,
WeaponlLocker, PlayerStart, PathNode, Teleporter, StaticMeshActor, Mover]

Note:

1) Static meshes collision volume is not ported.
2) Only normal lights are ported. (SunLight not ported, ...)



3) Navigation points = pathnodes + playerstarts.

4) Terrain is not ported yet but will be available in future versions.

5)

UT3 Converter does not port custom code used in a map.

Requirements

In order the program to run correctly you must have:

100MB free of hard disk space (used mainly to export all textures/sounds/staticmeshes from
input map)

An Intel Pentium 4 processor or above

512 Mb of memory

Windows Xp, Windows Vista operating system

Java 1.6 installed (see www.java.com for installation)

Unreal Tournament 3 game installed

Any other Unreal Tournament game installed (except UT3): Unreal 1, Unreal 2,Unreal
Tournament, Unreal Tournament 2003 or Unreal Tournament 2004.

Installation

For the installation, just extract the file UT3Converter-v0.22.zip to any folder you want keeping the

internal folder structure.

Once it’s done you should have these files installed:

<myfolder>/lib — librairies used by program

<myfolder>/nconvert — texture format conversion

<myfolder>/pvw32con — texture format conversion

<myfolder>/sox — Sound format conversion

<myfolder>/config.xml — Configuration File

<myfolder>/readme.txt

<myfolder>/ut3converter.jar - Program

<myfolder>/ut3converterfix.jar - Fix for staticmeshes naming

<myfolder>/ UT99TexPackinfo.txt — texture filenames database for Unreal Tournament

First use and configuration


http://www.java.com/

Execute the file “UT3converter.jar”. 2 windows should appear on screen:

7

|£| UT3 Converter | o[ |

| %] Convertion Qutput Log = | B b
File Help

UT3 Converter

Welcome ko UT3 Converter!

This program allows you ko convert partially UTx maps to UT3.

IF this is the First time you run the program configure the UT games
folder at the configuration panel (File- =Configure).

In order to convert a map do:
File-=Convert Map ...
Then fallow the instructions.

If it does not appear, check that you have Java version 1.6 or above installed. (www.java.com)
Now that you have the program running, you need to configure it to set game folders.

To do so go to File->Configure:

| £ UT3 Converter

Help

Comwvert... C

Configure Ctrl+C

Ctrl+Q)

This window should appear on screen:

[£| UT3 Converter Configuration Iﬁ

| Unreal 1 | Unreal 2 | UTa9 | UT2003 || UT2004 | Convertion |

Unreal Tournament 2004 Folder:

H:\UnrealAnthology|UT 2004

[ OK H Cancel ]

For each game you have installed on your computer specify their root folder. (“Select”)

For example, if you have installed Unreal Tournament 2004 in the folder
“H:\UnrealAnthology\UT2004” then set this folder as root folder.


http://www.java.com/

[£| UT3 Converter Configuration ﬁ

| Unreal 1 | Unreal 2 [ UT99 | UT2003 | UT2004 | Convertion

Default Input Folder:

seleck

Qutput Folder (where .t3d Files will be saved):

C:\Users|Hyperion|Documents| My Games

[ oK ][ Cancel ]

The conversion sub-window is used to set default output folder, where all the files will be created
when conversion will be done. Just select whatever folder you want, just make sure you have
permissions to write on this folder.

So now you are ready to convert maps! Let’s go then!

Map conversion

UT2004 Map conversion example

Configuration and checks
In order to show you how this program convert UT2004 map we gonna convert AS-TempleOfTrials-
V4 which can be downloaded here: (this will work of course for any other UT2004 map)

AS-TempleOfTrials-V4 (filefront)

Install map in the map folder of your UT2004 folder:<ut2004folder>/maps.

Run program and make sure you have set the UT2004 folder and the output folder in the
configuration panel (see previous section).

Make sure <outputfolder>/UT3Map is empty. If not delete all files and folder inside this folder
(UT3Map).

Export and conversion of map ressources
When all is done go to File->Convert in the menu:


http://files.filefront.com/AS+TempleOfTrials+v4rar/;4221426;/fileinfo.html

| £ UT3 Converter

Help

Configure Ctrl+C -

Exit Ctrl+0Q) ‘

e ——
|£| UT3 Converter - Conversion ﬁ
Select the input game:
Unreal Tournament 2004 -

Select vour map:

H:\UnrealAnthology|UT 2004 \Maps|AS-TempleOFTrials-v4 . ut2

Convertion options

Brushes Pickups Textures
Lights Mavigation Points StaticMeshes
Weapans Terrain Sounds

Once this window appears:

Specify input game for the map (here it’s “Unreal Tournament 2004”)
Specify map to convert (“Select”)
Specify which actors/stuff you want to convert

When all is set click on “Next”. The program will now convert the UT2004 map to UT3 executing
these different steps:
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Export of map to .t3d file

Identification of sounds used in map

Export of sounds to <outputfolder>/UT3Map/Sounds

Deletion of unused sounds

Conversion of sounds to Wav-16 bit format

Identification of staticmeshes used

Export of staticmeshes to <outputfolder>/UT3Map/StaticMeshes
Deletion of unused staticmeshes

Conversion of staticmeshes from .t3d to .ase format

10) Identification of textures used

11) Export of texture packages used

12) Deletion of unused texture packages



13) Conversion of textures files to .dds
14) Conversion of UT2004 map t3d file to UT3 t3d file.

F

[£| Convertion Output Log =HECINL X
17 sept. 2008 08:57:02 org. jdesktop.application.SessionStorage restoreTree -

ATTEMTION: Mo saved state for javax.swing.JTabbedPane[jTabbedPane,10,11,492x28
——————=== | JT3 Converter ==========

Converting H\UnrealAnthologAUT2004\Waps\AWS-TempleOfTrials-vd.ut2

Exporting map to t3dfile ...Done (11.694 s)

Getting Sounds packages names used ....Done (0.143 5)

4 packages sounds used

[CutdoorAmbience, IndoorAmbience, AnnouncerFemaleZk4, WeaponSounds]

7 sounds files used

[BThunder.caveambience3, BThunderwind4, BThunder Wind2, interior27, interior34, Ge
Exporting Sounds files to wav files ...

1l4———=0utdoorAmbience...Done

2ld——=Indoordmbience... .Daone

Md——-—=AnnouncerFemale2k4d... Dane

4ld—-—>=WeaponSounds....Done

Deleting unused sounds .. [BThunder.caveambience3, BThunder.wind4, BThunder \Win
Dane (61.0 Mb saved)

Caonverting sounds to wav 16 bit format ...

1 {——=BThunder.caveambience3d.wav...Done

27 ——=BThunder Wind2.wav...Done

37 ———=BThunderwind4. wav...Done

4ff—=Generic.Deniedwav....Done

A —=interior27 wav...Done

(=} miwmbm i e A saama Mmoo
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The conversion takes about 3 minutes depending how big your map is and how powerfull your
processor is. This map conversion took 270s with an Intel Quad Core Q6600 processor.

| £ UT3 Conwverter - Conversion ﬁ

Your map has been successfully converted!

Mow open the UT3 map editor and create a new map in "Subtractive Maode"
Go ko the Menu: File-=Import and browse for this file:
C:\Users|Hyperion|Documents| My Games|UT3Map|AS-TempleOfTrials-v4.t3d

After the impart is done, rebuild vour map.




Because there is a bad renaming of StaticMeshes files (UT3Map/StaticMeshes/), execute the
program UT3ConverterFix that will rename correctly them. Select the UT3Map/StaticMeshes/ press
ok and that’s all!

| £ Select the StaticMeshes folder of converted map u

Rechercher dans : |ﬁ UT3Map |'| E

3 Sounds

[ ] StaticMeshes

T Textures

MNom de fichier : |C:\Users\.Hyperion\Documents\My Games\WT3Map\StaticMeshes |

Fichiers dutype: |Tuus les fichiers | - |

Ouwvrir || Annuler |

Sélectionnez une option

E' Static Meshes names have been correctly renamed. You can now import them into the UT3 editor

| Oui H Non Hnnnuler‘

So now we got all files ready to be imported to the UT3 Editor!

UT3 Editor map import
Open the unreal editor

Create new map in substractive mode: File->New->Substractive mode:

Geometry Style

() Additive

Save your map with exactly the same name as the original UT2004 map:



[l Untitled - Unreal Editor for

File | Edit Wiew Brush Bu

Mew

Open...

Save Current Level

Save As

)

‘ Organiser « ggg
Liens favoris

Documents

Mam du fichier :

Type:

Affichages B Mouveau dossier

Mam Date de modification

L. Snowreal

DO | #® CookedPC b CustomMaps » - ﬂ- I Rechercher P

Type

|| A5-TCo-TheEgyptianPyramid-Final.ut3

Emplacements réce...

|| VCTF-[sWs]-MoParkingV2.ut3

WCTE furalancha i) k3

EI
!
B Bureau || VCTF-AggressiveAlleys3(Hot).ut3
| 18 Ordinateur || VCTF-AggressiveAlleys3(Wet).ut3
B Images || VCTF-AggressivehlleysClassic.ut3
! B Musique || VCTE-Alpine.ut3
| 5 Modifié récemment || WCTF-AltasCity.ut3
E Recherches || VCTF-AnarchyHalls.ut3
)| Public || WCTF-AncientFortressLV.ut3
|| VCTF-ArenaOfDeath.ut3
Dossiers | Il VCTF-Asunder.ut3 N

AS-TempleOfTrials-vd

Map files (*.ut3)

& Cacher les dossiers

Saving map with other filename as the original map will cause conversion of map to fail.

Note: you will be able to change the map filename when all the conversion process will be done.
(File->Save as).

Now we need to import ALL resources (textures, sounds, staticmeshes) used by the map before
importing it (<outputfolder>/UT3Map/AS-TempleOfTrials-v4.t3d).

To do so, open the generic browser:

Brush Build Tools Help

Browser Windows

e e e T [

%0 B(@E)

The File->Import so we import map resources.



B | Generic ‘ i Lo oo
File | View Docking
Mew... oups I Level IReFerencedAm i1t

: B OE @ i

Select all sound files in <outputfolder>/UT3Map/Sounds folder then click on “Open”:

Open...

Save...

[

Save As...

Import...
Export...

Recent 2

EI@ Packages
i [# CH_Gibs
-[B CH_Gore

1

1 [

0 Selected, 0 Total

Import of sounds

Import cm —
-

@Qv| <« UT3Map » Sounds v

‘ Organiser ~ &2 Affichages = BN

Rechercher

MNom : Artistes Album M= Genre »

Liens favoris
|#'| BThunder_caveambience3_16hits.wav
|| BThunder_Wind2_16bits.wawv
|| BThunder_wind4_16bits.wav

E| Documents

& Emplacements réce

L4 Buréau & interior27_16bits.wav
18 Ordinateur | | interior34_16bits.wav
E Images

E;“ Musique

& Modifié récemment
E Recherches
Public

Dossiers A

Mom du fichier : “interior34_16bits wav" "BThuni - [NI Files {*.dae;”bmp;” pcx;* fs V]

[ Quvrir IV] [ Annuler ]

e Find the package name AS-TempleOfTrials-V4 and set it as package name so resources will be
saved into the map (.ut3 file).

e Leave Group name blank

e Check bAutoCue

e Click on “Ok to All” (will import all sounds files at once)



Package @Dﬂ' rigls-v4 :::_) "
GO e )

Name BThunder _caveambience3_16bits

Build From File Path

Options

| »

bAutoCreateCue

bIncudeAttenuationNode
CueVolume 0.750000

m

Figure 1 - Sounds import

Import of textures

Like before, go to the generic browser and go to File->Import then select all textures used by the map
in <outputfolder>/UT3Map/Textures folder then click on “Open”:

i T sy e =5
18 | [

'
@Uv| ot UT3Map » Textures »

‘ Organiser ~ =zm8 Affichag

MNom ° Date de modification
. BMP
4 Base-bas03BA.psd

4 Base-bas04BA.psd

Liens favoris
E| Documents

| E Emplacements réce...

m

B Bureau ¥ Base-bas06BA.psd
1% Ordinateur ¥ Base-bas06BAb.psd
B Images 8 Base bas07BA.psd
E;h Musique *Base-basﬂba.psd
% Meodifié récemment *Ease-baslea.psd
E Recherches *Base-baseﬂlBO.psd
|\ Public *Ease-goldﬂl.psd
4 Borders-bdr01BA.psd
Dossiers A *Borders-bdrﬂZBA.psd i

Mom du fichier - "Walls-wal05BA ped” "Basebas + [.NI Files (" dae;” bmp;” pcx;” i v]

[ Ouvrir IV] [ Annuler ]

Like before set package name same as map filename, leave group blank.

But you also need to set to true “Create Material ?”



Info

Package®, AS-TempleOfTrials-v4 -

Group

Name Base-basl3BA

Build From File Path

Options

Alpha To Emissive |

Alpha To Opadity O

Alpha To Opacity Mask |

Alpha To Specular D

Blending [BLmD_Dpaque
CompressionNoAlpha |
CompressionSettings ['I‘C_Deﬁault
Create Material? ol 1 e
DeferCompression |

Dither Mip-maps alpha? |

FlipBook O

Lighting Mode! [MLM_thg

Then press “OK To All”.

The editor will now import all textures and create automatically materials. This operation can take
several minutes depending how many textures there are to import.

When the import is done we can see that textures are correctly imported but that materials are not
textured (grey spheres):

# Generic ——— @@lﬂ

File View Docking

Generic | Actor Classes I Groups | Level I Referenced Assets I Primitive Stats | Dynamic Shadow Stats I Scene Manager I Log

Show All Resource Types il Filter

Animation
AnimTrees
Archetypes
Camera Animation
Decal Material
FaceFX AnimSet

L FaceFX Asset
Font

I Lens Flare
Material

Material Tnetanre Canctant

m | »

-

@ [@ A_Weapon_Translocator &
1 AS-TempleOfTrials-v4*

Camera_FX

- [ CameraBlood : 4 s
5 CH_Al M ; atecil

CH_AnimCorrupt

&2
]
&
]
]
- [@ CH_AnimHuman Base-basO3BA
---- [ CH_AnimHuman_Tree Streamed 1024x1024[DXT1]
& ]
[
&2
£y

§ oy DO o O o O o DO o |
(E S C R E R E

CH_AnimKrall

CH_Corrupt_Cine
1 CH_Gibs

CH Gare

<« | m ’

-7
=

33 Selected, 76 Total




In order the sphere to be textured (material) for each material:

Double-click on it (open the “Unreal Material Editor”)

Drag the texture to the right

Close Windows

A window will pop-up asking you if you want to save changed to the material: answer yes.

§ Unreal Material Editor: AS-TempleOfT, ;als;v4.Base-baSO?aBA_Mat -
Window

99@ @0 TR+ v vV V
Preview: AS-TempleOfTrials-v4.Base-bas03BA_Mat X |

2
“Material Expressighs: AS-TX

-

GG
TELETHIETT
S[rznaizasionilzs

[ ComponentMask
[ranEiizsinnclsom Constant
ezl Constant?Vectar
=5 B ' Message - g!

EEbarlEE i N

)e &% Would you like to apply changes to this material to the original
V' material?
(No will lose all changes!) 3

Yes:)
Oui [_ Non j Annuler

-

Texture Texture2D'AS-TempleOfTrials-v4.Base-bas03BA'

bRealtimePreview
Desc

Properties: AS-TempleOfT X

=

File View Docking
Generic IAchor Classes | Groups | Level | Referenced Assets | Primitive Stats | Dynamic Shadow Stats I Scene Manager | Log ]
[V] Show All Resource Types @O VE 4 O ven

(25% | Filter
Animation ]
AnimTrees 3
Archetypes
Camera Animation
Decal Material
FaceFX AnimSet
FaceFX Asset
Font
Lens Flare 5 gy
Material - | - S T | |Base-bas03BA_Mat f
Material Tnetanre Canctant o = E " X 19 inStruCtiUns
1 textures

m. | »

PPPPPPPPE B BE

CH Gore

1 Selected, 76 Total

Figure 2 - The material is now textured!



Repeat this operation for all materials.

Import of staticmeshes.

Important: make sure you have imported textures before importing the staticmeshes. If not your
staticmeshes will not be textured!

Go to generic browser, file, import. Import all .ase files in :

<outputfolder>/UT3Map/StaticMeshes

Import e st — - ﬁ
- - £ Y = - - -

@Ov| |« UT3Map » StaticMeshes v [ 43 || Rechercher »
‘ Organiser ~ g38 Affichages ~ [ Mouveau dossier

liers favons Mom = Date de modification Type »

EI Documents | Deco_egypt_jumpad_staff.ase

. A || Decos_rec-lift.ase

1= Emplacements réce... = = -

7l GameObjects_MonitorA.ase

oo (T Tights ELight0lBA.ase

1% Ordinateur 7] Lights_ELight02BA.ase

B Images 7] Lights_ELight03BA.ase

E;h Musique | Maze_Cube.ase

% Modifié récemment 1 Maze_Glass.ase

E Recherches |7 Miscellaneous_ATopCorner@001BA.ase

|| Public ) Miscellaneous_Brazierl1BA.ase

|7 Miscellaneous_EWallOrnABA.ase
Daossiers A 1) Miscellaneous_EWallOrEBA.ase i
Mom du fichier : "Lights_ELight01BAase” "Light ~ Gﬁﬁc Mesh (".ase) j‘
| Ouvrir |'| [ Annuler ]

The import options windows appears:



Import

Info
[ te st =aelA S -TempleCfTrials v 4 -
Group >—<

Name Deco_egypt_jumpad_staff

=

Build From File Path

Options

None

bOneConvexPerUCKObject ]

| »

m

e Set package filename as input map filename
e Leave Group name blank
e Press “OKTo All”

You now have the staticmeshes imported and textured:



B Generic i =ACCgL X

File View Docking
Generic | Actor Classes | Groups | Level | Referenced Assets | Primitive Stats | Dynamic Shadow Stats | Scene Manager | Log

EE Q@@ O H 4 O ves25% ~ | Filter

Show All Resource Types

Sounds -
Speech Recognition
SpeedTree
v
Terrain Layer
Terrain Material
Texture
Texture (with alpha)
UI Prefabs
LI Scenes
LT Skins

[la ol =~ s N |

=) Packages B

m

4.

m

T mmimio o X

o Y S

PP REE

m

O O s 0 O O O e e

0 Selected, 40 Total

Import of UT3 T3D File:

This is the easiest operation go the Main menu: File->Import->Into Existing Map ...

(B AS-TempleOfTnals—+4 - Unreal Editor for Unreal Tourna

Edit View Brush Build Tools Help

Mew _ [ [;\}
Open- FEETE

Save Current Level

Save As..,
Save All

Force Save All

Export r Into Existing Map...

Recent L

Exit

| i |

Select TD3 File: <outputfolder>/UT3Map/<mapfilename>.t3d so in our case its



<outputfolder>/UT3Map/AS-TempleOfTrials-v4.t3d

Import g_
%' L My Games » UT3Map » w | +4 (M Rechercher L |
‘ Organiser ~ 828 Affichages ~ [ Mouveau dossier @
Liens favaris Nom ~ Date de m... Type Taille 3

[E Documents & Sounds
. . StaticMeshes
‘E—-._'fl_ Emnplacements réce...
1. Textures
) T [T AS-TempleOfTrials—vi. £3d
{8 Ordinateur || myLevel.22d
E Images
B’ Musique
[H Modifié récemment
E Recherches
|| ¢ Public
Dossiers -
Mem du fichier :  AS-TempleOf Trials-v413d - [UI'T&EJ Text {"13d) ']

[_Ouwr ] [ Annuer ]_:;

Click on “Open”. The editor will now import all actors of the UT2004 map.
After the import is done do. Tools->Clean BSP Materials.

Then rebuild your map and enjoy.



